We are continuing to work on a fix for this issue.
Posted Apr 13, 2024 - 15:22 EDT
Identified
Our data processing infrastructure is running behind which is causing degraded performance on our systems. No data has been lost and the system should be caught up shortly.
No need to contact support about this issue :)
Posted Apr 13, 2024 - 15:16 EDT
This incident affected: Credosa Internal Status (Credosa Employee Portal) and Credosa Member Portal, Credosa Billing and Payment System.